
Hypermedia, JSON Schema, HTTP, accessibility, security. Just an @awwright, didn't you hear I come in six packs?
Arizona, USA
Joined September 2018
- Tweets2.3K
- Following64
- Followers94
- Likes173
Austin_Wright retweeted
Replying to @awwscript @tmikov
If an API has particular requirements, it should use HTTP features, or be described in the ToS. Saying "you must use this particular software" is a roundabout way of saying "We have opaque terms of service, changed at any time, without notice or consent."
Austin_Wright retweeted
Would papers get rejected if they used legal code with variable names instead of Greek laden pseudo code?
Austin_Wright retweeted
to commemorate alan dye moving from apple to meta, here's one of his best quotes
Austin_Wright retweeted
Any need for virtual machines represents a complete failure of the modern operating system at its MOST IMPORTANT JOB: isolating processes and users from each other. (To paraphrase John Carmack)
Austin_Wright retweeted
Very interesting video by @dret and @awwscript about how greasing APIs makes them more robust. Definitely, something that I will have a closer look at in the future. youtu.be/EZOHviFcczI
Breaking #API clients is bad, right? Yes, but… for a robust ecosystem you need your clients to behave properly, and breaking clients *early* can improve the overall health of your API landscape. "When breaking API Clients is a Good Thing" with @awwscript: youtube.com/watch?v=EZOHviFc…
Austin_Wright retweeted
Will all of this newfangled AI/machine learning tech ever manage to predict if someone will like Napoleon Dynamite?
Austin_Wright retweeted
very happy to see this talk about "GREASE-ing" your APIs in order to improve future compatibility.
i first learned of this approach in RFC8701 (regarding TLS) (datatracker.ietf.org/doc/htm…) and @mnot's proposed "Greasing HTTP" draft (datatracker.ietf.org/doc/htm…)
#api360 #thanks
Breaking #API clients is bad, right? Yes, but… for a robust ecosystem you need your clients to behave properly, and breaking clients *early* can improve the overall health of your API landscape. "When breaking API Clients is a Good Thing" with @awwscript: youtube.com/watch?v=EZOHviFc…
Austin_Wright retweeted
Breaking #API clients is bad, right? Yes, but… for a robust ecosystem you need your clients to behave properly, and breaking clients *early* can improve the overall health of your API landscape. "When breaking API Clients is a Good Thing" with @awwscript: youtube.com/watch?v=EZOHviFc…
Austin_Wright retweeted
The HTTP section now describes the latest update to HTTP, RFC 9110:
fullstack.wiki/http/index
Austin_Wright retweeted
New revision 03 of The HTTP QUERY Method published. datatracker.ietf.org/doc/dra…
Austin_Wright retweeted
I agree with your Hammer analogy. Once upon a time, Blockchain was invented to hit a nail, and it was immensely satisfying.
Some people are trying to use it to hit babies, and that is not nearly as satisfying.
Austin_Wright retweeted
A list of Linux distributions without Systemd, what do you think?
itsfoss.com/systemd-free-dis…
#Linux #Systemd
Austin_Wright retweeted
The struggles of finding a job after graduation (v/@kevinkaywho)
Austin_Wright retweeted
RFC 9205: Building Protocols with HTTP rfc-editor.org/info/rfc9205
Austin_Wright retweeted
RFC 9110: HTTP Semantics rfc-editor.org/info/rfc9110
Austin_Wright retweeted
In other words, "{a}/{b}" can be parsed with the semantics of "{a}", for any {a} and {b} where "{a}" and "{a}/{b}" are both valid media types.
Austin_Wright retweeted
Replying to @dret @grahamcox82
I wish media types were arbitrarily hierarchical... e.g. "application/json/ld" would be what we call "application/ld+json"; and "application/json/ld/problem" would be a JSON-LD document that is guaranteed to use the Problem vocabulary.
Austin_Wright retweeted
Leaking secret tokens is one leading cause of security issues today. RFC 8959 defines the "secret-token" #URI scheme to make it easier to clearly identify and recognize secret tokens in your code, for example for more reliable security scanning. webconcepts.info/concepts/ur…
















